Is Beaver Builder compatible with Gutenberg?

Probably everyone has heard of Gutenberg by now. It's the project name for the new WordPress editor that's being developed.

The Beaver Builder plugin Version 2.1 or higher is compatible with Gutenberg in the same way that it's compatible with the "classic" WordPress text editor. Depending on whether you set WordPress to prefer the Gutenberg editor or classic editor in Settings > Writing > Class editor settings, you can choose the Beaver Builder editor, the "standard" Gutenberg editor, or the "classic" WordPress editor, and move text and images from one editor into another on a limited scale. For more details see the detailed article about how Beaver Builder 2.1 works with Gutenberg.

Tip: If you use the Beaver Builder Theme Version 1.7 or higher, Gutenberg blocks display type as formatted in Customizer settings.

We think Beaver Builder is far superior to the features that Gutenberg offers, but we encourage you to try Gutenberg and Beaver Builder for yourself. If you have a Beaver Builder license, you can download the current version of Beaver Builder from the My Account page, or you can install the free Beaver Builder Lite plugin.

Once you try both page builders side by side, we'd value your feedback on your experience. The best mechanism to get feedback directly to us is to submit a Support ticket.