Disable Font Awesome 4 loading in Beaver Builder Theme

Note: This article applies to versions of Beaver Builder Theme prior to Version 1.7. See the Related Article below for information about Font Awesome settings in Version 1.7.

Font Awesome Version 5 is not backwards-compatible with Font Awesome Version 4, and this has produced many headaches during the transition. Current versions of the Beaver Builder plugin let you choose whether to use Font Awesome 4 (for older sites that use FA4 icons or to maintain compatibility with other older plugins) or to use Font Awesome 5.

As of Beaver Builder Theme Version 1.7, you can choose which version of Font Awesome to load on the Customize > General > Layout tab. If you're using an older version of the Beaver Builder Theme and you're seeing problems such as blank boxes instead of icons, you can dequeue Font Awesome 4 to prevent the Beaver Builder Theme from loading it.

Add the following code to your child theme's  functions.php file:

Note: Be sure to add this code to a child theme, or it will be overwritten every time you update to a new version of the theme.